re = /(?<logtype>[^-]+)-(?<run_id>[^-]+)-(?<job_id>[^-]+)-(?<capability>.*?)-\d{2}\.\d{2}\.\d{2}/
str = 'PE-run1000hbgmm3f1-job1000hbgmm3dt-Output-Workflow-1000hbgmm3fb-22.07.17.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end