import Foundation
let pattern = ##"^([a-z]+://[^/,#?]*)[^,\n]*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,
https://community.domain.tld/register?tests,categorie,dateAcces,,,
https://community.domain.tld/register,categorie,dateAcces,,,
https://community.domain.tld/,categorie,dateAcces,,,
https://community.domain.tld,categorie,dateAcces,,,
https://community.domain.tld?to=dfgdfgdgf,categorie,dateAcces,,,
https://community.domain.tld#dfgdfgdgf,categorie,dateAcces,,,
https://community.domain.tld,categorie,dateAcces,,,
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)