import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \\(.*?\\)";
final String string = "icon-culture (2015_09_04 06_58_44 UTC).png\n"
+ "icon-disk (2015_09_04 06_58_44 UTC).png\n"
+ "icon-download (2015_09_04 06_58_44 UTC).png\n"
+ "icon-drop (2015_09_04 06_58_44 UTC).png\n"
+ "icon-file (2015_09_04 06_58_44 UTC).png\n"
+ "icon-film (2015_09_04 06_58_44 UTC).png\n"
+ "icon-flag (2015_09_04 06_58_44 UTC).png\n"
+ "icon-folder (2015_09_04 06_58_44 UTC).png\n"
+ "icon-garbage (2015_09_04 06_58_44 UTC).png\n"
+ "icon-graph (2015_09_04 06_58_44 UTC).png\n"
+ "icon-heart (2015_09_04 06_58_44 UTC).png\n"
+ "icon-help (2015_09_04 06_58_44 UTC).png\n"
+ "icon-lock (2015_09_04 06_58_44 UTC).png\n"
+ "icon-map (2015_09_04 06_58_44 UTC).png\n"
+ "icon-media (2015_09_04 06_58_44 UTC).png\n"
+ "icon-money (2015_09_04 06_58_44 UTC).png\n"
+ "icon-monitor (2015_09_04 06_58_44 UTC).png\n"
+ "icon-notes (2015_09_04 06_58_44 UTC).png\n"
+ "icon-openmail (2015_09_04 06_58_44 UTC).png\n"
+ "icon-phone (2015_09_04 06_58_44 UTC).png\n"
+ "icon-photo (2015_09_04 06_58_44 UTC).png";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}