$re = '/(\d{12})|./m';
$str = '|Голобородько Оксана|380530093768|105|0
|Тихонов Виталий Александрович|380670009567|106|0
|Загребная Анастасия|380666766678|108|123509747
|Оприско Юрий|380677795609|109|0
|Петришина Тетяна Євгеніївн|380759985008|111|0
|Ставчанская Алена|380670095848|112|0
|Солодовнік Сергій|380503452267|113|0
|Катерина Пасочна|380505587095|114|0
|Аліна Абаза|380506673487|115|0
|Виктория Леонардовна|380679903658|117|0
|Колесниченко Даниил|380676744578|118|0
|Степан Ростислав|380500094673|175|NULL
|Тамара Почкун|380951123459|176|NULL
|Пицур Михаил Романович|380687844567|119|0
|Подварский Анатолий|380676782547|120|0';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;