$re = '/aa.+(?<!x)$/m';
$str = 'aa1
aa2
aa1x
aa2x
b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);