# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h*<(?!(?:h3|ul|p)\b)([^>]+).*?>[\w\W]*?<\/\1>\s*//gm;t' <<< "<h1>This is heading 1</h1>
<h2 style=\"color: aqua\">This is heading 2</h2>
<h3>This is heading 3</h3>
<p>This is a paragraph.</p>
<p>This is another paragraph.</p>
<a href=\"https://www.w3schools.com\">This is a link</a>
<ul>
<li>Coffee</li>
<li>Tea</li>
<li>Milk</li>
</ul>"