re = /^[a-zA-Z0-9ČŠŽĐ](?:[A-Z0-9 ČŠŽĐ]{0,31}[A-Z0-9ČŠŽĐ])?$/i
str = '1000 Ljubljana'
# Print the match result
str.match(re) do |match|
puts match.to_s
end