$re = '/0*\K\d{2,3}(?=_\d)/m';
$str = 'ZATR0008_2018.pdf
ZATR0018_2018.pdf
ZATR0218_2018.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);