$re = '/(?<=\[)parameters\(\'[^\']+\'\)(?=\])/m';
$str = '[parameters(\'ECC_Shipment_Trigger_properties_pl_ecc_shipment_adls_sql_parameters_File_system\')]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);