re = /:(?<match>(?:[\w\-.~:?#\[\]@!$&'()*+,;=%]*)\d+)+/m
str = 'test1/test2/:test3
test1/:test2/test3
:test1/test2/test3
:test1/test2/test3/:test4 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end