$re = '/^(.*?)(\d*([-.]\d*)*)$/m';
$str = 'MyTexxxxxt 9.25-8.50';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);