$re = '/^.+$(?<!\.jpg)/m';
$str = '/file.txt
/file.jpg
/file.gif
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);