import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?data-extra-url=\".*?<\\/a>";
final String string = "<div> <br> <a data-some-id=\"3-6-9;id-1-2-3\" data-more-id=\"1-3-5\" data-extra-url=\"https://somehost.api/sub-id-1-2-3?someparam=3-6-9;id-1-2-3\" href=\"https://somehost.api/sub-id-1-2-3?someparam=3-6-9;id-1-2-3\" class=\"some-class\">someDuplicateHere1</a></div> wysiwyg<br> <div><a class=\"popup-wrap-id-1-2-3\" href=\"https://somehost.api/app/id-1-2-3?someparam=sub-id-1-2-3;sub-sub-id-1-2-3\">firstImage</a></div> <br> <div>somecontent</div> <div> <span> <div><a data-some-id=\"456;789\" href=\"https://somehost.api/app/id-4-5-6?someparam=sub-id-4-5-6;sub-sub-1-2-3\">second</a></div> <br> </span> also some more content </div> <div> <span> <div><a data-some-id=\"3-6-9;id-1-2-3\" data-more-id=\"1-3-5\" data-extra-url=\"https://somehost.api/app/sub-id-1-2-3?someparam=3-6-9;id-1-2-3\" href=\"https://somehost.api/app/sub-id-1-2-3?someparam=3-6-9;id-1-2-3\" class=\"some-class\">someDuplicateHere</a></div> rtf<br> </span> <br> </div> </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}