$re = '/^([^-\n\r]+ - ){2}[^-\s]+$/m';
$str = 'abc - xyz - 123
abc - xyz - 123 - a
- - - - -
_ - ____ - _
÷÷ - ÷ - ÷÷÷
- - x
-- [^-\\n\\r] não pega quebras de linha
abc - fad
fdas - fda';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);