re = /^([\wÀ-ú ]+ - ){2}[\wÀ-ú]+$/m
str = 'abc - xyz - 123
abc - xyz - 123 - a
- - - - -
_ - ____ - _
÷÷ - ÷ - ÷÷÷
- - x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end