$re = '/(?:\[+)(.+?)(?:\]+)/';
$str = '[[[hello-hello]]
[[hi-hi]]]
[[hi hi]]]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;