$re = '/^ab(.*ab)?$/m';
$str = 'ab
abb
abab
abc er 56 &()) ab';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);