use strict;
my $str = 'a {color: red !important;}
#p1 {
margin-top: 20px !important
}
/* Client-specific styles */
.ExternalClass,
.ExternalClass p,
.ExternalClass span,
.ExternalClass font,
.ExternalClass td,
.ExternalClass div {
line-height: 100%;
}
a {}
@media query {
a {
display:none
}
}
a
{ display:none }
}
/* Media query for mobile viewport
#asset_container * Developer: hero graphics should be 2 x width for HD rendering.
*/
@media only screen and (max-width: 480px){
table[class=max-width-pad] {
max-width: 100% !important;
width: 100% !important;
padding-top: 15px !important;
height: auto !important;
}
#asset_container table[class=max-width]{
max-width: 100% !important;
width: 100% !important;
height: auto !important;
}
#asset_container table[class=container]{
margin: 0 auto !important;
}
#asset_container .desktop-masthead{
display: none !important;
}
#asset_container *[class].hidden. *[class=desktop-masthead]{
display: none !important;
}
#asset_container *[class].elastic{
width: 100% !important;
height: auto !important;
}
#asset_container *[class].centered{
text-align: center !important;
}
#asset_container *[class].fluid, #asset_container [class=fluid-mob]{
width: 100% !important;
}
[class=fluid-mob] {
#asset_container position: relative;
}
.mobile-show{
display: table-cell !important;
width: auto !important;
height: auto !important;
max-height: none !important;
overflow: visible !important;
visibility: visible !important;
position: relative !important;
text-align: center !important;
}
#asset_container .show-mob{
display: block !important;
max-height: none !important;
width: auto !important;
visibility: visible !important;
}
#asset_container *[class].mob-masthead{
width: 100% !important;
display: block !important;
height: auto !important;
max-height: none !important;
padding: 0 !important;
}
#asset_container *[class].mob-masthead-img{
position: absolute !important;
top: 0px !important;
display: block !important;
height: auto !important;
max-height: none !important;
padding: 0 !important;
width: auto !important;
}
[class=fluid-mob] {
display: table-cell !important;
width: auto !important;
height: auto !important;
max-height: none !important;
overflow: visible !important;
visibility: visible !important;
position: relative !important;
text-align: center !important;
}
}
';
my $regex = qr/^(?!.*@media)[\t ]*([a-zA-Z#.:*[][^{\/]*\s*){[\s\S]*?}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}