$re = '/^\W*?(\W)(?=.*?\b\1\W*$)/m';
$str = '!@#$%""<>test (string")-+/;,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);