$re = '/(^\d+)([a-z]{1}|\d)/m';
$str = '29c
29
1
29cdsd
c
2425315651252fsaw
24241jl.421c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);