use strict;
my $str = 'VALID_SUPPORTED
-hello@world.co
hello.world@co.co
simple@example.com
underscore@in_domain.net
simple@example.com.
very.common@example.com
संपर्क@डाटामेल.भारत
disposable.style.email.with+symbol@example.com
медведь@с-балалайкой.рф
other.email-with-hyphen@example.com
fully-qualified-domain@example.com.
user.name+tag+sorting@example.com
Pelé@example.com
x@example.com
example-indeed@strange-example.com
test/test@test.com
böb@example.com
BÖB@gmail.com
example@s.example
mailhost!username@example.org
user%example.com@example.org
user-@example.org
20401@some.email
MAYBE_VALID_MAYBE_SUPPORTED
domain.end.with.nums@no.good.127
mason@日本.com
user@example.😀
☹️@hello.world
VALID_UNSUPPORTED
hns@neel
admin@mailserver1
" "@example.org
"john..doe"@example.org
"very.(),:;<>[]\\".VERY.\\"very@\\\\ \\"very\\".unusual"@strange.example.com
postmaster@[123.123.123.123]
postmaster@[IPv6:2001:0db8:85a3:0000:0000:8a2e:0370:7334]
INVALID
hello..world@co.co
hello@world-.co
hello@.world.co
Abc.example.com
A@b@c@example.com
a"b(c)d,e:f;g<h>i[j\\k]l@example.com
just"not"right@example.com
this is"not\\allowed@example.com
this\\ still\\"not\\\\allowed@example.com
1234567890123456789012345678901234567890123456789012345678901234+x@example.com
i_like_underscore@but_its_not_allowed_in_this_part.example.com
QA[icon]CHOCOLATE[icon]@test.com';
my $regex = qr/^(?:[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-]|[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-](?:[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-]|\.(?!\.)){0,62}[\p{L}\p{M}\p{N}!#$%&'*+/=?^`{|}~-])@(?:[\p{L}\p{M}\p{N}]|[\p{L}\p{M}\p{N}][\p{L}\p{M}\p{N}_-]{0,61}[\p{L}\p{M}\p{N}])(?:\.(?:[\p{L}\p{M}\p{N}]|[\p{L}\p{M}\p{N}][\p{L}\p{M}\p{N}_-]{0,61}[\p{L}\p{M}\p{N}]))+\.?$/ump;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}