package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+.+){10}`)
var str = `abababababababababa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}