re = /\bq=\b(.*)/m
str = '/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=ymca+student+pass
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=years+of+service+award
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=yearbooks
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=yearbook
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=year+book
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=Yaping+Tu
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=yahoomail
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=y+hr
/search/results/?cx=015839161432768919274:z2n1gijj14s&cof=FORID:9&ie=UTF-8&q=xrays
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end