$re = '/(?!^[~!@#$%^&*().]+$)^([\u4e00-\u9fa5]*|[\da-zA-Z~!@#$%^&*.]){0,30}$/';
$str = '~!@#$%^&**hJUYTREWQWS水电费水电费Dfds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);