$re = '/(\d)(?=\d\1)/';
$str = '121426
523563
552523
333567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);