$re = '/^(?:\d{1,2}|\d{4,})?$/m';
$str = '1
23
123
1234
12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);