$re = '/(?:(\d+)(?=\,|\s|$))+/';
$str = '3123123213212,3123123263212,3173123213212';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);