$re = '/AC\d{8}|(\d+)/m';
$str = '((AC00001234 + AC00005678) / 365) * (5 + 10)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);