use strict;
my $str = 'CD:\\:abc\\\\\\:there:';
my $regex = qr/(?<!\\)((?:\\{2})*):/mp;
my $subst = '\\g<1>newstr';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";