re = /^[A-Z][a-z]+ ?(?:-[A-Z][a-z]+ ?)?$/m
str = 'John
John
John-Doe
John-Doe
John
John Doe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end