$re = '/\([0-9.]+%\)/';
$str = 'Hello my name is (0.9%) and (15%) bye (10.5%) also (C9, B6)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);