// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)(?i)Rozliczenie[\s\a]*VAT[\s\a]*Netto[\s\a]*Podatek[\s\a]*Brutto[\s\a]*[-]*wg[\s\a]*stawki[\s\a]*(?<StVAT>\d{1,2}.0%)[\s\a]*[\s\S]*Razem[\s]*:[\s]*(?<WartoscNetto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<KwotaVAT>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))\s*(?<WartoscBrutto>(\d{1,3}\.\d{1,3},\d{2}|\d{1,3},\d{2}))[\s\a]*Do\s*Zapłaty\s*:\s*(?<DoZaplaty>\k<WartoscBrutto>)").unwrap();
let string = "AKTURA FV000821 :JAAC*fibf:
DATA WYSTAWIENIA : 2020.06.08 ZLECENIE: 01
MIEJSCE WYSTAWIENIA : TORUŃ
DATA DOSTAWY TOWARU : 2020.06.08 UWAGI : zam. T561552 Z1
SPRZEDAWCA: \"MEGA-TOOLS\" S.C.
Marek Śpiewak,Mirosław Śpiewak ul.Osikowa 34 87-100 Toruń NIP 9562093313
ING Bank Śląski S.A. O/Toruń
49 1050 1979 1000 0022 7285 0849
NABYWCA: Pojazdy Szynowe PESA Bydgoszcz Spółka Akcyjna ul.Zygmunta Augusta 11 85-082 Bydgoszcz
NIP 554-031-17-75
[07-668]
Lp Opis towaru/uslugi Ilość jm. Cena Wartosc VAT
-----------------------------------------------------------------------------------------------
1 INNE-ELEK-9512 11. szt. 66,00 726,00 23.0% Lampa warsztatowa 30LED z ładowarką
---------------------------------------------------------------------------------------------- 726,00
Rozliczenie VAT Netto Podatek Brutto ----------------------------------------------------wg stawki 23.0% : 726,00 166,98 892,98 -----------------------------------------------------
RAZEM : 726,00 166,98 892,98
DO ZAPŁATY: 892,98 PLN
SŁOWNIE : osiemset dziewiecdziesiat dwa zl dziewiecdziesiat osiem gr
ZAPLACONO GOTOWKA : 0,00 PLN
POZOSTAŁO DO ZAPŁATY : 892,98 PLN
PŁATNE : PRZELEW DO 2020.08.07
NA KONTO : 49 1050 1979 1000 0022 7285 0849
Za niezapłacone należności w terminie, będą naliczone odsetki w wysokości ustawowej.
Dokument wystawiony i dostarczony nabywcy w formie elektronicznej.
Wystawca dokumentu FV000821 : MIROSŁAW ŚPIEWAK
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}