re = /\[([^\]]+)\]\(([^"“”]+)(?: [\"|\“]([^\"“”]+)[\"|\”])?\)/
str = '[some text](http://google.com "title")'
# Print the match result
str.match(re) do |match|
puts match.to_s
end