re = /(?<=[a-z])(?=[A-Z])/m
str = 'Strawberry JamApple
BananaPear CrumblePotato
Almond Cake'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end