$re = '/\*[^*]*\*/m';
$str = '*something here*another stuff here';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;