import re
regex = re.compile(r"^[a-zA-Z0-9][\w\-\.]*(?<![^a-zA-Z0-9])@(?![^a-zA-Z0-9])(?:[\w\-]+(?<![^a-zA-Z0-9])\.)+[a-zA-Z]{2,}$", flags=re.MULTILINE)
test_str = ("user@gmail.com\n"
"personal@corpmail.com\n"
"personal@sub.domain.com\n"
"user-name@mail.student\n"
"user.name@gmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")