#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=^[\t ]*|[\n;](?:[\t ]*(?:\w+ )?)?)export(?:(?: *(?<type>type) *)|[\t\n ]*)(?<exports>(?:\*(?: +as +\S+)?)|\S+|(?:{[\w\t\n\r "$'*,./-]+?}))[\t ]*from[\t ]*["']\s*(?<specifier>(?:(?<=' *)[^']*[^\s'](?= *'))|(?:(?<=" *)[^"]*[^\s"](?= *"))) *["']"
Local $sString = "export { default } from './make'" & @CRLF & _
"export { " & @CRLF & _
" DEFAULTS," & @CRLF & _
" plugin as default," & @CRLF & _
" type Options" & @CRLF & _
"} from './plugin'" & @CRLF & _
"export type { Config, Result } from './interfaces'" & @CRLF & _
"export type { default as Options } from './options'" & @CRLF & _
"export type Foo from '#foo'" & @CRLF & _
"" & @CRLF & _
"export type * from "./spaceship"" & @CRLF & _
"export type * as vehicles from "./spaceship"" & @CRLF & _
"export * as constants from './constants'" & @CRLF & _
"export * from './interfaces'" & @CRLF & _
"export * from './lib'" & @CRLF & _
"export * from './types'" & @CRLF & _
"export * from "module-name";" & @CRLF & _
"export * as name1 from "module-name";var g;export{name1}from"module-name";" & @CRLF & _
"export { name1, /* */ nameN } from "module-name";" & @CRLF & _
"export { import1 as name1, import2 as name2, /* */ nameN } from "module-name";" & @CRLF & _
"export { default, /* */ } from "module-name";" & @CRLF & _
"" & @CRLF & _
"declare module 'module-name' {" & @CRLF & _
" export { default } from './make'" & @CRLF & _
" export { " & @CRLF & _
" DEFAULTS," & @CRLF & _
" plugin as default," & @CRLF & _
" type Options" & @CRLF & _
" } from './plugin'" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
" export {" & @CRLF & _
" DEFAULTS," & @CRLF & _
" plugin as default," & @CRLF & _
" type Options" & @CRLF & _
" }" & @CRLF & _
" export { defineBuildConfig, type BuildConfig } from "#src"" & @CRLF & _
" export type {" & @CRLF & _
" JsonObject," & @CRLF & _
" LiteralUnion," & @CRLF & _
" Nullable" & @CRLF & _
" } from '@flex-development/tutils'" & @CRLF & _
" export {" & @CRLF & _
" addFive," & @CRLF & _
" addFour," & @CRLF & _
" addThree," & @CRLF & _
" addTwo," & @CRLF & _
" squareFive," & @CRLF & _
" squareFour," & @CRLF & _
" squareThree," & @CRLF & _
" squareTwo" & @CRLF & _
" } from './lib'" & @CRLF & _
" export * as constants from "./constants"" & @CRLF & _
" export type { default as Options }" & @CRLF & _
" export type { default as Options } from "./options"" & @CRLF & _
" export * from './utils'" & @CRLF & _
" export interface User {}" & @CRLF & _
" export abstract class House {}" & @CRLF & _
" export const { name1, name2: bar } = o;" & @CRLF & _
" export const [ name1, name2 ] = array;" & @CRLF & _
" export default async function foo() {}" & @CRLF & _
" export default foo" & @CRLF & _
" export default 1 + 1;" & @CRLF & _
" export type { Config, Result }" & @CRLF & _
"" & @CRLF & _
""export type { default as Statement }"" & @CRLF & _
"" & @CRLF & _
"export { name1, /* */ nameN };" & @CRLF & _
"export { variable1 as name1, variable2 as name2, /* */ nameN };" & @CRLF & _
"export { variable1 as "string name" };" & @CRLF & _
"export { name1 as default /*, */ };" & @CRLF & _
"export type { CompilerOptionsJson as default };" & @CRLF & _
"export { default }" & @CRLF & _
"export { " & @CRLF & _
" DEFAULTS," & @CRLF & _
" plugin as default," & @CRLF & _
" type Options" & @CRLF & _
"}" & @CRLF & _
"export type { Config, Result }" & @CRLF & _
"export type { default as Options }" & @CRLF & _
"" & @CRLF & _
"var g;export{name1}; export{name1}" & @CRLF & _
"export { name1, /* */ nameN }" & @CRLF & _
"export { import1 as ", import2 as name2, /* */ nameN }" & @CRLF & _
"export { default, /* */ }" & @CRLF & _
"" & @CRLF & _
"// export * from './constants'" & @CRLF & _
"" & @CRLF & _
"// export type { default as Statement }" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" *" & @CRLF & _
" * @example" & @CRLF & _
" * export { default }" & @CRLF & _
" * export { Config, Result }" & @CRLF & _
" * export type { default as Options }" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"// export * from './constants'" & @CRLF & _
"" & @CRLF & _
"//export type { default as Statement } from './statement'" & @CRLF & _
"" & @CRLF & _
"/* export type { default as Statement } from './statement' */" & @CRLF & _
"" & @CRLF & _
"/*export type { default as Statement } from './statement' */" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" * @example" & @CRLF & _
" * export * from './constants'" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * @example" & @CRLF & _
" * export * from './constants'" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" *" & @CRLF & _
" * @example" & @CRLF & _
" * export { default } from './make'" & @CRLF & _
" * export { Config, Result } from './interfaces'" & @CRLF & _
" * export type { default as Options } from './options'" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"export type { Config, Result } from './interfaces'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")