import re
regex = re.compile(r"\ ", flags=re.MULTILINE)
test_str = ("cat and dog.mp3\n"
"rihana and shakira.mp3\n"
"me and ma.mp3")
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)