re = /(?<!\\),/
str = 'CN=Firstname Lastname\\, Organization,OU=some ou,DC=company,DC=com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end