$re = '/^(?!.*?([A-Z]).*\1)([A-Z]{2})([ ][A-Z]{2})*$/m';
$str = 'AB CD XY
AB BC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);