re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[@$!%*?&**£€^(){}:"|<>\/**])[A-Za-z\d!$%@#£€*?&]{8,}$/m
str = 'pR@ad33pa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end