import Foundation
let pattern = #"[ \t]*(CATCH_)?(TEMPLATE_)?(TEST_CASE_METHOD|SCENARIO|TEST_CASE)[ \t]*\([ \t\n]*\"[^\"]*\"[ \t\n]*(,[ \t\n]*\"[^\"]*\")?(,[ \t\n]*[^,\)]*)*\)+[ \t\n]*\{+[ \t]*(//[^\n]*[Tt][Ii][Mm][Ee][Oo][Uu][Tt][ \t]*[0-9]+)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TEST_CASE ("test")
{
Hello world;
}
TEST_CASE ("test with spaces {} []")
{
Hello world;
}
TEST_CASE ("test ) ", "case")
{
Hello world;
}
TEST_CASE ("test () ")
{
Hello world;
}
TEST_CASE("all is good")
{
REQUIRE(true);
}
TEMPLATE_TEST_CASE("aa", "[]", int, double, foo) {
}
CATCH_TEMPLATE_TEST_CASE("foo", "[tag]", T1, T2) {
}
CATCH_TEST_CASE("bbb") {
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)