re = /(\[QUOTE[^][]*\]
(?:[^][]++|(?1))++
\[\/QUOTE\])
\Z/xm
str = 'Here is the example post text
[QUOTE]
This is an appropriate quote
[/QUOTE]
Here is more post content
Here is the example post text
[QUOTE]
This is an appropriate quote
[/QUOTE]
Here is more post content
[QUOTE]
This is an unnecessary quote, as it\'s below all of the post text
[QUOTE]
Here\'s an unnecessary nested quote, just to confuse things.
[/QUOTE]
[/QUOTE]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end