$re = '/^[^ ]+([ ][^ ]+)+$/s';
$str = 'François Dupont
Marie-France Dupont Aignant
A B
A
François énervé et couché';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);