package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<firstname>[a-z]+)(?<lastname>[A-Z]\w*)`)
var str = `firstName
slackUser`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}