import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[0-9a-z]{32}\\b";
final String string = "d3bd55bf-062f-473b-9417-935f62c4c98a\n"
+ "d3bd55bf062f473b9417935f62c4c98a\n"
+ "d3bd-55bf062f473b9417935f62c4c98a\n"
+ "d3bd55-bf06-2f473b9417-935f62c4c98a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}