$re = '/\b([A-Z])\w*(?:\s+\w+)*?\s*\(\1[A-Z]*\)/mi';
$str = 'Some example text (SET) that demonstrates what I\'m looking for. Energy system models (ESM) are used to find specific optima (SCO). Some say computer systems (CUST) are cool. In the summer playing outside (OUTS) should be preferred.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);