$re = '/^(^[^.]*)\.(\S+\.\S*)$/m';
$str = 'www.google.com
google.com
registro.br
br';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);