re = /(?<=^The\s)(?<service>.*)\s(?=service\sentered)service\sentered\sthe\s(?<state>\w+)\sstate\.$/m
str = 'The McAfee Validation Trust Protection Service service entered the running state.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end