$re = '/(?<![^\W_])foo(?![^\W_])/i';
$str = 'foo_foo_foo foo-foo_foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);